Video Infusion Pro v3.2.0 Addon Implementation

Última actualización hace 6 mes
Super Administrador

Equipo Colaboradores

Talocha Publicado hace 6 mes
Video Infusion Pro v3.2.0 by NetriX Website:
About This Infusion This is an infusion that will allow you to upload your own videos through the administration panel, embed custom video/media source, and add YouTube videos and custom source urls. You also have the option to configure the look of your video player's skin through the administration page. Features -Video CMS - Video Upload - YouTube Compatible - Addon Implementation - Share Features - High Definition Setting - Highly Customizable - Supported Video (flv mp4 mov f4v 3gp 3g2 mp3 flac) Developer Notes I had a lot of fun in creating this addon for the community. While minor versions of this infusion were emphasized around getting a general direction of where to take this infusion, I personally feel were getting ever closer to my original concept along with user suggestions with version 3. This infusion was created with simplicity in mind and the intent to produce a more stable environment for its purpose in use. Installation Guide Step #1 Upload the contents of the infusion into all the respective directories. - UPLOAD\administration\images >> ROOT/administration/images/ -UPLOAD\infusions ideo >> ROOT/infusions/video/ - UPLOAD\includes\user_fields >> ROOT/includes/user_fields/ - UPLOAD\locale\English\user_fields >> ROOT/locale/English/user_fields/ Step #2 Navigate to: Admin Panel > System Admin > Infusions Select "Video" from drop down menu. Click "Infuse". Upgrading Infusion Navigate to: Admin Panel > System Admin > Infusions Select Video from drop down menu (should be green). Click "Infuse". Unistalling Infusion Navigate to: Admin Panel > System Admin > Infusions Under Infused Infusions find "Videos" Click "Defuse". Developer Tips / Debug Problems Infusion Not Installing One instance of the bug not allowing one to install the infusion is if the infusion was previously installed and not all data was removed after defusing. The solution would be to remove the table "NXV" under the row "admin_rights" in "dbprefix_admin" in phpmyadmin. Another simple solution would be to preview the following code in a custom page, take note I said to "preview" only.

dbquery("DELETE FROM ".DB_ADMIN." WHERE admin_rights='NXV'");
Video Not Uploading Usually when using a free host, file uploads are not allowed to a certain extent - one measure being excessive file size. Regardless, you can usually check the php configuration settings along with a defined max upload size in the Video Admin (Admin Panel > Infusions > Video Admin > Manage Settings). As of version 3.0.0 I've coded the script to display the max php configuration upload allowed, along with a max script upload defined by the end-user. The "Max Allowed by PHP Configuration" should not exceed that of the "Max File Size" as they should remain even if possible. One common mistake is that the php configuration file is not configured correctly to allow bigger download files to be uploaded. You'll need to find your php.ini file and edit the following: Do not make file changes unless you know what your doing! Contact your host if your troubled. You can find the php configuration file usually in: "usr/bin/apache/apache[?]/bin/php.ini". If not, refer to Admin Panel > System Admin > PHP Info > Details (Locate "Loaded Configuration File"). In your PHP.INI file, ensure the following parameters are met. File Uploads are ON

file_uploads = On
Upload Max Filesize is larger than, if not the same as Max Upload Size defined in Video Infusion Script.

; Maximum allowed size for uploaded files. ; upload_max_filesize = 100M
As we're using POST data to upload videos along with images, you'll also need to ensure the post_max_size in your php configuration file is large enough to handle post data. Search out post_max_size in php.ini.

; Maximum size of POST data that PHP will accept. ; post_max_size = 100M 
Their is also a maxium time PHP will accept input calculated in seconds. You'll need to ensure you have enough time allowed for upload to process.

; Default Value: -1 (Unlimited) ; Development Value: 60 (60 seconds) ; Production Value: 60 (60 seconds) ; max_input_time = 60 
If you do not have access to php.ini and your server supports .htaccess then you can insert the following into the .htaccess file.

php_flag file_uploads on php_value post_max_size "100M" php_value upload_max_filesize "100M" php_value max_input_time "-1"
Change the values to satisfy your needs. Other than the information provided, lookout for error displays when attempting to check the error log for problems. Report any found problems @ for further support.
Copyright 2017 NetriX @ All Rights Reserved.
Usted puede ver todos los temas de discusión en este foro.
Usted no puede iniciar un nuevo tema de discusión en este foro.
Usted no puede responder en este tema de discusión.
Usted no puede empezar en una encuesta en este foro.
Usted no puede subir archivos adjuntos en este foro.
Usted no puede descargar archivos adjuntos en este foro.
Usuarios que participaron en la discusión:Talocha